$re = '/^([^\n]+)\s*([^\n]+) (\$[^\n]+)\s*([^\n]+)\s*([^\n]+)$/si';
$str = '190 PALMER RD, HARMONY
MLS® 201512263 $239,900
2 ACRES/HEATED DBL GARAGE/HEAT PUMP
http://goo.gl/tVWDan';
$subst = "<p style=\"color: #EF2F48\"><b>$1</b></p><p>$2  $3</p> <p style=\"color: #000\">$3</p> <p><a class=\"ui-link\" style=\"color: blue;\"href=\"$4\" target=\"_blank\">$5</a></p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;