using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(r'([a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z]))', r'\1 ')";
string substitution = @"";
string input = @"2010";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}