re = /(r'([a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z]))', r'\1 ')/
str = '2010'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result