use strict;
my $str = '2010';
my $regex = qr/(r'([a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z]))', r'\1 ')/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";