const regex = new RegExp('(r\\'([a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z]))\\', r\\'\\1 \\')', 'g')
const str = `2010`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);