import Foundation
let pattern = #"(r'([a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z]))', r'\1 ')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2010"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)