# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[0-9]{3}-[0-9]{3}-[0-9]{4}$//gm;t' <<< "888-999-6666
666-666-666
666666666"