#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[0-9]{3}-[0-9]{3}-[0-9]{4}$"
Local $sString = "888-999-6666" & @CRLF & _
"666-666-666" & @CRLF & _
"666666666"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)