const regex = /^[0-9]{3}-[0-9]{3}-[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{3}-[0-9]{3}-[0-9]{4}$', 'gm')
const str = `888-999-6666
666-666-666
666666666`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);