$re = '/^[0-9]{3}-[0-9]{3}-[0-9]{4}$/m';
$str = '888-999-6666
666-666-666
666666666';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;