use strict;
my $str = '888-999-6666
666-666-666
666666666';
my $regex = qr/^[0-9]{3}-[0-9]{3}-[0-9]{4}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";