import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)";
final String string = "BEGIN:VCALENDAR\n"
+ "VERSION:2.0\n"
+ "PRODID:-//ABC Corporation//NONSGML My Product//EN\n"
+ "BEGIN:VTODO\n"
+ "DTSTAMP:19980130T134500Z\n"
+ "SEQUENCE:2etc...";
final String subst = "\"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}