re = /(.+)/m
str = 'BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//ABC Corporation//NONSGML My Product//EN
BEGIN:VTODO
DTSTAMP:19980130T134500Z
SEQUENCE:2etc...'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result