import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(import)[\\s|\\n]*\\{(.+)\\}[\\s|\\n]*from[\\s|\\n]*'..\\/..\\/(.+)';";
final String string = "import {OrdresView} from '../../Components/OrdresView/ordres-view.ts';\n"
+ "import {OrdreItem} from '../../Components/OrdresView/OrdreItem.ts';\n"
+ "import {NavManager} from'../../Utils/nav_manager/NavManager.ts';\n\n\n";
final String subst = "$1 $2 ($3)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}