import Foundation
let pattern = #"(import)[\s|\n]*\{(.+)\}[\s|\n]*from[\s|\n]*'..\/..\/(.+)';"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
import {OrdresView} from '../../Components/OrdresView/ordres-view.ts';
import {OrdreItem} from '../../Components/OrdresView/OrdreItem.ts';
import {NavManager} from'../../Utils/nav_manager/NavManager.ts';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 ($3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)