// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(import)[\s|\n]*\{(.+)\}[\s|\n]*from[\s|\n]*'..\/..\/(.+)';").unwrap();
let string = "import {OrdresView} from '../../Components/OrdresView/ordres-view.ts';
import {OrdreItem} from '../../Components/OrdresView/OrdreItem.ts';
import {NavManager} from'../../Utils/nav_manager/NavManager.ts';
";
let substitution = "$1 $2 ($3)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}