# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(import)[\s|\n]*\{(.+)\}[\s|\n]*from[\s|\n]*'..\/..\/(.+)';"
test_str = ("import {OrdresView} from '../../Components/OrdresView/ordres-view.ts';\n"
"import {OrdreItem} from '../../Components/OrdresView/OrdreItem.ts';\n"
"import {NavManager} from'../../Utils/nav_manager/NavManager.ts';\n\n\n")
subst = "$1 $2 ($3)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.