$re = '/(import)[\s|\n]*\{(.+)\}[\s|\n]*from[\s|\n]*\'..\/..\/(.+)\';/i';
$str = 'import {OrdresView} from \'../../Components/OrdresView/ordres-view.ts\';
import {OrdreItem} from \'../../Components/OrdresView/OrdreItem.ts\';
import {NavManager} from\'../../Utils/nav_manager/NavManager.ts\';
';
$subst = "$1 $2 ($3)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;