use strict;
my $str = 'import {OrdresView} from \'../../Components/OrdresView/ordres-view.ts\';
import {OrdreItem} from \'../../Components/OrdresView/OrdreItem.ts\';
import {NavManager} from\'../../Utils/nav_manager/NavManager.ts\';
';
my $regex = qr/(import)[\s|\n]*\{(.+)\}[\s|\n]*from[\s|\n]*'..\/..\/(.+)';/ip;
my $subst = '$1 $2 ($3)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";