#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\d+)\.+\d+\.(\d+)\.+\d+$"
Local $sString = "16.0.8730.1000" & @CRLF & _
"17.2.444444.1" & @CRLF & _
"16.0.1000" & @CRLF & _
"16.0.1000.0.0" & @CRLF & _
"16.0.1000.0a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")