using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\.+\d+\.(\d+)\.+\d+$";
string input = @"16.0.8730.1000
17.2.444444.1
16.0.1000
16.0.1000.0.0
16.0.1000.0a";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}