re = /^(\d+)\.+\d+\.(\d+)\.+\d+$/
str = '16.0.8730.1000
17.2.444444.1
16.0.1000
16.0.1000.0.0
16.0.1000.0a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end