use strict;
my $str = '16.0.8730.1000
17.2.444444.1
16.0.1000
16.0.1000.0.0
16.0.1000.0a';
my $regex = qr/^(\d+)\.+\d+\.(\d+)\.+\d+$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}