import Foundation
let pattern = #"^(\d+)\.+\d+\.(\d+)\.+\d+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
16.0.8730.1000
17.2.444444.1
16.0.1000
16.0.1000.0.0
16.0.1000.0a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)