import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|([ \\t]){2,}|(?:\\r?(\\n)){2,})";
final String string = "Envelopes/Env. Thick/Env. Thin 0 pages\n\n\n"
+ "Label 0 pages\n\n\n"
+ "Hagaki 0 pages\n\n\n\n"
+ "Replace Count\n\n\n"
+ "Drum Unit 0\n\n\n"
+ "Toner 0";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}