re = /(?|([ \t]){2,}|(?:\r?(\n)){2,})/
str = 'Envelopes/Env. Thick/Env. Thin 0 pages
Label 0 pages
Hagaki 0 pages
Replace Count
Drum Unit 0
Toner 0'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result