# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?|([ \t]){2,}|(?:\r?(\n)){2,})"
test_str = ("Envelopes/Env. Thick/Env. Thin 0 pages\n\n\n"
"Label 0 pages\n\n\n"
"Hagaki 0 pages\n\n\n\n"
"Replace Count\n\n\n"
"Drum Unit 0\n\n\n"
"Toner 0")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.