#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(.+?)(?<!(?<!\\)\\{2})\]"
Local $sString = "+------------------+----------------+" & @CRLF & _
"| Input | Output |" & @CRLF & _
"+------------------+----------------+" & @CRLF & _
"| [B] | B |" & @CRLF & _
"| [B][C][D] | B |" & @CRLF & _
"| [hello\t\tworld] | hello\t\tworld |" & @CRLF & _
"| [hello\n\nworld] | hello\n\nworld |" & @CRLF & _
"| [\\]] | \\] |" & @CRLF & _
"| [\\\\] | \\\\ |" & @CRLF & _
"| [x[y\\]z][foo] | x[y\\]z |" & @CRLF & _
"+------------------+----------------+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")