using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.+?)(?<!(?<!\\)\\{2})\]";
string input = @"+------------------+----------------+
| Input | Output |
+------------------+----------------+
| [B] | B |
| [B][C][D] | B |
| [hello\t\tworld] | hello\t\tworld |
| [hello\n\nworld] | hello\n\nworld |
| [\\]] | \\] |
| [\\\\] | \\\\ |
| [x[y\\]z][foo] | x[y\\]z |
+------------------+----------------+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}