re = /\[(.+?)(?<!(?<!\\)\\{2})\]/m
str = '+------------------+----------------+
| Input | Output |
+------------------+----------------+
| [B] | B |
| [B][C][D] | B |
| [hello\\t\\tworld] | hello\\t\\tworld |
| [hello\\n\\nworld] | hello\\n\\nworld |
| [\\\\]] | \\\\] |
| [\\\\\\\\] | \\\\\\\\ |
| [x[y\\\\]z][foo] | x[y\\\\]z |
+------------------+----------------+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end