import Foundation
let pattern = #"\[(.+?)(?<!(?<!\\)\\{2})\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+------------------+----------------+
| Input | Output |
+------------------+----------------+
| [B] | B |
| [B][C][D] | B |
| [hello\t\tworld] | hello\t\tworld |
| [hello\n\nworld] | hello\n\nworld |
| [\\]] | \\] |
| [\\\\] | \\\\ |
| [x[y\\]z][foo] | x[y\\]z |
+------------------+----------------+
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)