#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(require|include)(_once)?\s*\(?['"]"
Local $sString = "require('lofasz.php')" & @CRLF & _
"" & @CRLF & _
"require ('akarmi.php')" & @CRLF & _
"require 'akarmi.php'" & @CRLF & _
"include 'akarmi.php'" & @CRLF & _
"" & @CRLF & _
"require_once "akarmi.php"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")