// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(require|include)(_once)?\s*\(?['"]"#).unwrap();
let string = "require('lofasz.php')
require ('akarmi.php')
require 'akarmi.php'
include 'akarmi.php'
require_once \"akarmi.php\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}