using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(require|include)(_once)?\s*\(?['""]";
string input = @"require('lofasz.php')
require ('akarmi.php')
require 'akarmi.php'
include 'akarmi.php'
require_once ""akarmi.php""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}