import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(require|include)(_once)?\\s*\\(?['\"]";
final String string = "require('lofasz.php')\n\n"
+ "require ('akarmi.php')\n"
+ "require 'akarmi.php'\n"
+ "include 'akarmi.php'\n\n"
+ "require_once \"akarmi.php\"\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}