re = /(require|include)(_once)?\s*\(?['"]/
str = 'require(\'lofasz.php\')
require (\'akarmi.php\')
require \'akarmi.php\'
include \'akarmi.php\'
require_once "akarmi.php"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end