#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^((?<AddressType>\w+\s*)?(?<Unit>\d+\s*)\/)?(?<StreetNumber>(\s*(\d+\w+)+)|((\s*\d+\s*\-\s*\d+)))(?<StreetNameAndType>(?<StreetType>\s+\w+)+)\s*[,|.]?\s*(?<Suburb>[\w\s]+)\s+(?<PostCode>\d{4})$"
Local $sString = "1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030" & @CRLF & _
"37A DAINTREE CL, SOUTH BOWENFELS NSW 2790" & @CRLF & _
"unit 11/18-22 bernecker st .Carina 4152" & @CRLF & _
"445 VICTORIA RD,RYDALMERE 2116" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)