$re = '/^((?<AddressType>\w+\s*)?(?<Unit>\d+\s*)\/)?(?<StreetNumber>(\s*(\d+\w+)+)|((\s*\d+\s*\-\s*\d+)))(?<StreetNameAndType>(?<StreetType>\s+\w+)+)\s*[,|.]?\s*(?<Suburb>[\w\s]+)\s+(?<PostCode>\d{4})$/mi';
$str = '1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030
37A DAINTREE CL, SOUTH BOWENFELS NSW 2790
unit 11/18-22 bernecker st .Carina 4152
445 VICTORIA RD,RYDALMERE 2116
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;