use strict;
my $str = '1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030
37A DAINTREE CL, SOUTH BOWENFELS NSW 2790
unit 11/18-22 bernecker st .Carina 4152
445 VICTORIA RD,RYDALMERE 2116
';
my $regex = qr/^((?<AddressType>\w+\s*)?(?<Unit>\d+\s*)\/)?(?<StreetNumber>(\s*(\d+\w+)+)|((\s*\d+\s*\-\s*\d+)))(?<StreetNameAndType>(?<StreetType>\s+\w+)+)\s*[,|.]?\s*(?<Suburb>[\w\s]+)\s+(?<PostCode>\d{4})$/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";