const regex = /^((?<AddressType>\w+\s*)?(?<Unit>\d+\s*)\/)?(?<StreetNumber>(\s*(\d+\w+)+)|((\s*\d+\s*\-\s*\d+)))(?<StreetNameAndType>(?<StreetType>\s+\w+)+)\s*[,|.]?\s*(?<Suburb>[\w\s]+)\s+(?<PostCode>\d{4})$/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?<AddressType>\\w+\\s*)?(?<Unit>\\d+\\s*)\\\/)?(?<StreetNumber>(\\s*(\\d+\\w+)+)|((\\s*\\d+\\s*\\-\\s*\\d+)))(?<StreetNameAndType>(?<StreetType>\\s+\\w+)+)\\s*[,|.]?\\s*(?<Suburb>[\\w\\s]+)\\s+(?<PostCode>\\d{4})$', 'mig')
const str = `1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030
37A DAINTREE CL, SOUTH BOWENFELS NSW 2790
unit 11/18-22 bernecker st .Carina 4152
445 VICTORIA RD,RYDALMERE 2116
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);