import re
regex = re.compile(r"^((?<AddressType>\w+\s*)?(?<Unit>\d+\s*)\/)?(?<StreetNumber>(\s*(\d+\w+)+)|((\s*\d+\s*\-\s*\d+)))(?<StreetNameAndType>(?<StreetType>\s+\w+)+)\s*[,|.]?\s*(?<Suburb>[\w\s]+)\s+(?<PostCode>\d{4})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030\n"
"37A DAINTREE CL, SOUTH BOWENFELS NSW 2790\n"
"unit 11/18-22 bernecker st .Carina 4152\n"
"445 VICTORIA RD,RYDALMERE 2116\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)