import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?<AddressType>\\w+\\s*)?(?<Unit>\\d+\\s*)\\/)?(?<StreetNumber>(\\s*(\\d+\\w+)+)|((\\s*\\d+\\s*\\-\\s*\\d+)))(?<StreetNameAndType>(?<StreetType>\\s+\\w+)+)\\s*[,|.]?\\s*(?<Suburb>[\\w\\s]+)\\s+(?<PostCode>\\d{4})$";
final String string = "1 / 124 OLD SOUTH HEAD RD,VAUCLUSE 2030\n"
+ "37A DAINTREE CL, SOUTH BOWENFELS NSW 2790\n"
+ "unit 11/18-22 bernecker st .Carina 4152\n"
+ "445 VICTORIA RD,RYDALMERE 2116\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}