#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=-\d)\.(?=\d-)"
Local $sString = "E-1-2-3.1-0-0 or E-1-2-0-2.5-0 or E-1-2-0-3.5-0 like this some text I have ." & @CRLF & _
"" & @CRLF & _
"But in my text some places 2.5, 56.7 like these numbers"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")