re = /(?<=-\d)\.(?=\d-)/
str = 'E-1-2-3.1-0-0 or E-1-2-0-2.5-0 or E-1-2-0-3.5-0 like this some text I have .
But in my text some places 2.5, 56.7 like these numbers'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end