import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=-\\d)\\.(?=\\d-)";
final String string = "E-1-2-3.1-0-0 or E-1-2-0-2.5-0 or E-1-2-0-3.5-0 like this some text I have .\n\n"
+ "But in my text some places 2.5, 56.7 like these numbers";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}