import Foundation
let pattern = #"(?<=-\d)\.(?=\d-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
E-1-2-3.1-0-0 or E-1-2-0-2.5-0 or E-1-2-0-3.5-0 like this some text I have .
But in my text some places 2.5, 56.7 like these numbers
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)