const regex = /(?<=-\d)\.(?=\d-)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-\\d)\\.(?=\\d-)', 'g')
const str = `E-1-2-3.1-0-0 or E-1-2-0-2.5-0 or E-1-2-0-3.5-0 like this some text I have .
But in my text some places 2.5, 56.7 like these numbers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}