# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\p{Lu})(\p{Lu}+)/$1\L$2/gm;t' <<< "dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
"