use strict;
my $str = 'dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
';
my $regex = qr/(\p{Lu})(\p{Lu}+)/mp;
my $subst = '$1\\L$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";