import Foundation
let pattern = #"(\p{Lu})(\p{Lu}+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\L$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)